Cloudflare Network Performance Issues

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 14:12 GMT

Update

Cloudflare have entered an extended observation period to ensure the integrity of the fix.
Posted Dec 19, 2025 - 13:07 GMT

Monitoring

Cloudflare have implemented a fix and will continue to monitoring the results.
Posted Dec 19, 2025 - 12:41 GMT

Investigating

Cloudflare have reported intermittent issues with network performance, which is currently being investigated. Customers might observe unexpected errors.
Posted Dec 19, 2025 - 12:12 GMT
This incident affected: Intelligent Shipper API Services, Intelligentshipper.net, Intersoftsapient.net, Sapient API Services, and Intelligentshipper.cn.