CN Domain down

Resolved

ICP licence renewal is in the process.
Posted Mar 31, 2025 - 17:37 BST

Update

We are continuing to investigate this issue.
Posted Mar 31, 2025 - 17:37 BST

Update

We'd like to let you know that we're currently having issues with our China domain due to the revocation of our ICP Licence. We are actively working with our service provider to resolve this situation, but unfortunately, the resolution timeline is beyond our control.
While we work towards a solution, you can use intelligentshipper.net as an alternative to create your shipments. This should help minimise any disruption until our provider resolves the issue.
We appreciate your patience and understanding. If you have any questions or need assistance, please don’t hesitate to reach out to our support team.
Posted Mar 31, 2025 - 09:39 BST

Investigating

We are currenlty investigating the issue as https://cn.intelligentshipper.cn domain is down.
Please use the alternative domain https://cn.intelligentshipper.net
Posted Mar 30, 2025 - 10:30 BST
This incident affected: Intelligentshipper.cn.