We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 15:18 GMT
Monitoring
A fix has been implemented by Cloudflare and we believe the incident is now resolved. We are continuing to monitor for errors to ensure all services are back to normal.
Posted Nov 18, 2025 - 14:48 GMT
Update
Cloudflare have deployed a change which has restored their dashboard services. They are still working to remediate broad application services impact.
Posted Nov 18, 2025 - 14:37 GMT
Identified
Cloudflare has identified the issue and is currently implementing a fix.
Posted Nov 18, 2025 - 13:15 GMT
Update
Cloudflare reports that services are recovering; however, customers may still experience elevated error rates as remediation efforts continue.
Posted Nov 18, 2025 - 12:30 GMT
Investigating
We have received reports of Cloudflare Global Network experiencing issues. Cloudflare is aware of the issue and are investigating the issue which potentially impacts multiple customers. Further detail will be provided as more information becomes available.
Posted Nov 18, 2025 - 11:56 GMT
This incident affected: Intelligent Shipper API Services, Intelligentshipper.net, Intersoftsapient.net, Sapient API Services, and Intelligentshipper.cn.