We are continuing to monitor for any further issues
Posted Feb 28, 2025 - 08:58 GMT
Update
We are continuing to monitor for any further issues.
Posted Feb 26, 2025 - 07:25 GMT
Update
Cloudflare have implemented a fix and are monitoring the results.
Posted Feb 26, 2025 - 07:23 GMT
Monitoring
Cloudflare has deployed additional traffic engineering mechanisms & continue working on further improvements
Posted Feb 24, 2025 - 10:50 GMT
Update
Cloudflare has deployed additional traffic engineering mechanisms & continue working on further improvements.
Posted Feb 19, 2025 - 19:10 GMT
Identified
Cloudflare has identified the issue and is working on implementing a fix for the network Performance Issues in China.
Posted Feb 18, 2025 - 07:20 GMT
Investigating
Cloudflare is investigating issues with performance in China. Some end-users located in China may see an increase in errors or timeouts trying to reach specific Cloudflare IPs.